I-8058 User's Manual

Digital Input | Input Channel | 8 Channels
 | Input Type | Isolated differential digital input
 | ON State | Minimum 80VAC
 | OFF State | Maximum 30VAC
 | Peak Voltage | 250VAC
 | AC Frequency | Minimum 45Hz
 | Input Impedance | 68K Ohms
 | Isolation Voltage | 3750 Vrms
LED Display | 1 LED as Power/Communication indicator 8 LEDs as digital input indicators
Power Consumption | Maximum : 0.2W

I-8058-PinAssignment
Terminal Number | Pin Name
5 | DI0A
6 | DI0B
7 | DI1A
8 | DI1B
9 | DI2A
10 | DI2B
11 | DI3A
12 | DI3B
13 | DI4A
14 | DI4B
15 | DI5A
16 | DI5B
17 | DI6A
18 | DI6B
19 | DI7A
20 | DI7B

I-8058 Block Diagram

Input Type ON State
LED ON
Readback as 1 		OFF State
LED OFF
Readback as 0
Relay Contact
Relay Close I-8058 Digital Input
Relay Open I-8058 Digital Input

I-8058 Dimention

Back to Previous Page


I-8058 Slave Command Sets

I-8058 Command Sets for Slave I-8000 Series(I-8411,I-8811)
Command | Description
$AASi6 | Read Digital Input OR Read Back Digital Output

Back to Previous Page


I-8000 Command Sets

Command
$AASi6
Description
This command for readback the Digital Output module
value and read the Digital Input module value
in the specified Slot of the I-8000 system.
Syntax
$AASi6[CHK](cr)
$ | a delimiter character
AA | address number of the I-8000 system. AA= 00 ~ FFh
Si | slot number of the module. i = 0 ~ 3 or 0 ~ 7
6 | Command for read data
[CHK] | 2 characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the command
Response
Valid Command
!0D0E00[CHK](cr) for 8 bits DIO modules
!DD0000[CHK](cr) for 8 bits (or less than 8 bits) DO modules
!EE0000[CHK](cr) for 8 bits (or less than 8 bits) DI modules
!DDEE00[CHK](cr) for 16 bits DIO modules
!DDDD00[CHK](cr) for 16 bits DO modules
!EEEE00[CHK](cr) for 16 bits DI modules
!DDDDEEEE[CHK](cr) for 32 bits DIO modules
!DDDDDDDD[CHK](cr) for 32 bits DO modules
!EEEEEEEE[CHK](cr) for 32 bits DI modules
Invalid Command ?AA[CHK](cr)
Syntax error or communication error may get no response.
! | delimiter for valid command
? | delimiter for invalid command
D | 4 bits output value (0~Fh)
E | 4 bits input value (0~Fh)
DD | 8 bits output value (00~FFh)
EE | 8 bits input value (00~FFh)
DDDD | 16 bits output value (0000~FFFFh)
EEEE | 16 bits input value (0000~FFFFh)
DDDDDDDD | 32 bits output value (00000000~FFFFFFFFh)
EEEEEEEE | 32 bits input value (00000000~FFFFFFFFh)
[CHK] | 2-characters of Checksum
(cr) | Character Return(0x0D) for denote the end of the response
Example

Command | $01S16
Response | !0155AA00
Description | The example read the digital I/O module value from slot 1 of the I-8000 system at address 01h.The second 2-character 55h (01010101) indicate the I/O module channels 8,10,12,14 are ON and the channels 9,11,13,15 are OFF. The third 2-character AAh(10101010) indicate the I/O module channels 1,3,5,7 are ON and the channels 0,2,4,6 are OFF.
Command | $01S16
Response | !01550000
Description | The example read the digital I/O module value from slot 1 of the I-8000 system at address 01h.The second 2-character 55h (01010101) indicate the I/O module channels 1,3,5,7 are ON and the channels 0,2,4,6 are OFF.
Modules
I-8040,I-8041,I-8042,I-8050, I-8051, I-87051, I-8052, I-87052
, I-8053 ,I-87053, I-8054, I-87054, I-8055, I-87055, I-8056
,I-8057, I-87057, I-8058, I-8060, I-8063, I-87063
,I-8064, I-87064, I-8065, I-87065, I-8066, I-87066
,I-8068, I-87068

Back to Previous Page


Command/Response String and Checksum
Command/Response Format
Command Format | (Leading)(Address)(Command)[CHK](cr)
Response Format | (Leading)(Address)(Response)[CHK](cr)

(Leading) | Leading character, like ~, $, #, @, %, !, ?, >.
(Address) | Address of specificed module, from 00 to FF. For some command like #**, the address is ** for all modules.
(Command/Response) | Command with parameters or response with data.
[CHK] | 2-character checksum. If the CheckSum is disabled, no [CHK] here.
(cr) | end-of-command character, character return(0Dh)

Calculate Checksum
  1. Calculate ASCII sum of all characters of (Leading), (Address) and (Command)(or (Response)).
  2. Mask the sum of string with 0ffh, or said only take the last 2 digits of the hex value of the sum.
    For example, if the sum is 01BCh, take the "BC" as the [CHK].

Example
  • Command string : $012
    1. Sum of string = `$'+`0'+`1'+`2' = 24h+30h+31h+32h = B7h

    2. The checksum is B7h, and [CHK] = "B7"

    3. Command string with checksum : $012B7(cr)

  • Response string : !01070600
    1. Sum of string : `!'+`0'+`1'+`0'+`7'+`0'+`6'+`0'+`0' =
      21h + 30h + 31h + 30h + 37h + 30h + 36h + 30h + 30h = 1AFh

    2. The checksum is AFh, and [CHK] = "AF"

    3. Response string with checksum : !01070600AF
      4. (cr)

Back to Previous Page


I-8000Series User's Manual

On-Line User's Manual Master And Slave
Item | Description
Slave In the slave mode the I-8000 Series can be controlled by the host machine as a distributed I/O front ends.It receive the command from the host by the comunication port, then explain the command and execute the command. So it waste the time to receive command,explain command and echo result.It can't be use for the control that must take care of the timing.
It advantage is easy to use, user doesn't take care of the hardware structure. The user only need to know how the command work.
Master | In the Master mode the I-8000 Series can operate as an embedded application. The user must write himself application program and download into main control unit.
What is MASTER/SLAVE of I-8000 Series ? The 8K485.EXE is a SLAVE firmware, it can be download into the main control unit & make it act as a SLAVE device similar to 7000 series. When the I-8000 series(8410/8810) is shipping, it is download with AUTOEXEC.BAT & 8K485.EXE.So the I-8000 series(8410/8810) will automatically execute the 8K485.EXE when the power is applied (INIT* pin OPEN). When the 8410/8810 execute the 8K485.EXE, it is a SLAVE device. If the INIT* pin & INIT* COM pin are short together,user can download new user program into 8410/8810 to make it act as a MASTER device.
When the 8411/8811 is shipping, it is master.Only the MIniOS7 in the main control unit.
How to change the 8410/8810 to a MASTER device ? The working steps are giving as following:
  • step 1: short the INIT* pin & INIT*COM pin together
  • step 2: power up & download user's application program & AUTOEXEC.BAT into 8410/8810
  • step 3: power down & open the INIT* pin
  • step 4: power up, the 8410/8810 will start to execute user's program & act as a MASTER device.
How to change the 8411/8811 to a Slave device ? The working steps are giving as following:
  • step 1: short the INIT* pin & INIT*COM pin together
  • step 2: power up & download 87K485.EXE & AUTOEXEC.BAT into 8411/8811
  • step 3: power down & open the INIT* pin
  • step 4: power up, the 8411/8811 will start to execute 87K485.EXE & act as a SLAVE device.

Back to Previous Page